nlogn求逆序数 POJ 2299解题报告

前几天自己想出了利用归并排序求逆序数的方法,找了一个求逆序数的题2299 交了300++MS水过...

 

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 19686   Accepted: 6959

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
#include<iostream>
using namespace std;

__int64 sum=0;

int *guibing(int *data,int n)
{
	int i,j,k,L,R,s;	int *now;
	for(i=2;i<n*2;i=i<<1)
	{
		now=new int[n];
		for(j=0;j<=n/i;j++)
		{
			k=L=i*j;	R=L+i/2;	s=0;
			while(L<n&&R<n&&L<i*j+i/2&&R<i*(j+1))
			{
				if(data[L]<=data[R])
				{
					now[k++]=data[L++];
					sum+=s;
				}
				else
				{
					now[k++]=data[R++];
					s++;
				}
			}
			while(L<n&&L<i*j+i/2)
			{
				now[k++]=data[L++];
				sum+=s;
			}
			while(R<n&&R<(j+1)*i)
				now[k++]=data[R++];
		}
		delete data;
		data=now;
	}
	return data;
}

int main()
{
	int n,i;
	int *data;
	while(cin>>n&&n)
	{
		sum=0;
		data=new int[n];
		for(i=0;i<n;i++)
			scanf("%d",data+i);
		data=guibing(data,n);
		delete data;
		printf("%I64d/n",sum);
	}
} 

你可能感兴趣的:(Algorithm,Integer,delete,input,output,sorting)