网上都多这样的文章,看来看去还是得总结一下,也许会引用一些东西...
总之,在那些unix系统上装Oracle10g,首先就要先"磨刀",就是确定你的OS版本,确定Oracle需要的
gcc,jdk,jre等等一些软件环境是否达到Oracle10g的要求.
比如
Oracle10g要安装在linux上的话,目前只支持这几个版本:
Red Hat Enterprise Linux 2.1
Red Hat Enterprise Linux 3
Novell SUSE Linux Enterprise Server 8
所以,首先要确定OS版本.
另外在linux上安装oracle10g,要修改一些它的内核,这些在网上很多......
又比如要在HP-UX上安装Oracle10g
确定你的HP-UX版本,(过几天我要在HP-UX 11iv2上安装)
For all installations on HP-UX 11i v2 (11.23), the following patches are required:
BUNDLE11i B.11.23.0409.3: Patch Bundle for HP-UX 11i V2
Note: You must have the August 2004 version of BUNDLE11i B.11.23.0408.1 for HP-UX 11i v2 on
your system prior to updating to the HP-UX 11i v2 September 2004 or later release.
PHCO 32426: Reboot(1M) cumulative patch
PHKL 32646: wsio.h header file patch
PHKL 32632: Message Signaled Interrupts (MSI and MSI-X)
PHKL 32645: SIO (IO) subsystem MSI/MSI-X/WC Patch
PHKL 33552: VM Copy on write data corruption fix
PHSS_31850: 11.23 assembler patch
PHSS_31851: 11.23 Integrity Unwind Library
PHSS_31854: 11.23 milli cumulative patch
PHSS_31855: 11.23 aC++ Runtime (IA: A.05.60, PA A.03.60)
PHSS_33275: 11.23 linker + fdp cumulative patch
PHSS_33276: 11.23 Math Library Cumulative Patch
For PL/SQL native compilation and installation of Pro*C/C++, Oracle Call Interface, Oracle
C++ Call Interface, or Oracle XML Developer's Kit (XDK), the following C and C++ patches are
required:
PHSS_33278: aC++ Compiler
PHSS_33279: aC++ Compiler
PHSS_33277: HP C Compiler
PHSS_33279: HP C Compiler
For all installations, the following JDK patches are required:
PHCO_31553: s700_800 11.23 pthread library cumulative patch
PHKL_31500: s700_800 11.23 sept04 base patch
PHSS_32213: s700_800 11.23 aries cumulative patch
上面的也就是说HP-UX的版本要是11.23,而且下面的这些patches都要在安装前检查一下
# /usr/sbin/swlist -l patch | more
确保他们被安装上然后,在执行后面的安装.
上面这些就是"磨刀".
后面做的大家估计很熟悉了,建立用户组,用户,授予权限,开终端显示,调整字符集,设置环境变量.然后安
装.
下面是如果没安装X11MotifDevKit.MOTIF21-PRG的话要执行
Note: This task is required only if the Motif 2.1 Development
Environment package (X11MotifDevKit.MOTIF21-PRG) is not
installed.
To enable you to successfully relink Oracle products after installing this software, enter
the following commands to create required X library symbolic links in the /usr/lib
directory:
# cd /usr/lib
# ln -s libX11.3 libX11.so
# ln -s libXIE.2 libXIE.so
# ln -s libXext.3 libXext.so
# ln -s libXhp11.3 libXhp11.so
# ln -s libXi.3 libXi.so
# ln -s libXm.4 libXm.so
# ln -s libXp.2 libXp.so
# ln -s libXt.3 libXt.so
# ln -s libXtst.2 libXtst.so
下面是检查机器的内存和硬盘空间
1. To determine the physical RAM size, enter the following command:
# /usr/contrib/bin/machinfo | grep -i Memory
2. To determine the size of the configured swap space, enter the following command:
# /usr/sbin/swapinfo –a
3. To determine the amount of free disk space in the /tmp directory, enter the
following command:
# bdf /tmp
4. To determine the amount of free disk space on the system, enter the following
command:
# bdf
5. To determine if the system architecture can run the software, enter the following
command:
# /bin/getconf KERNEL_BITS
Alternatively, to list all installed patches, enter the following command:
# /usr/sbin/swlist -l patch | more
#sam 进入system administrator manager
在其中选择kernel configuration,进入以后在选择configurable parameters 修改以下参数 MAXDSIZ 1073741824
MAXDSIZ_64 2147483648
MAXSSIZ 134217728
MAXSSIZ_64 1073741824
MAXUSERS 1000
NPROC 20+8*MAXUSERS
SEMMNI 500
SEMMNS 1000
SEMMSL 2048
SEMVMX 32767
SEMMNU 500
SHMMAX 1073741824 (我配的那台机器最大允许就是这个值,应该是配最大的物理内存)
SHMMNI 512
SHMSEG 200
VPS_CEILING 64
mount
# /usr/sbin/umount /SD_DVD
# /usr/sbin/mount -F cdfs -o rr /dev/dsk/cxtydz /SD_DVD
如果是HP-UX B.11.11以下的版本
#nohup /usr/sbin/pfs_mountd &
#nohup /usr/sbin/pfsd &
#/usr/sbin/pfs_mount -t rrip -x unix /
/dev/dsk/c0t1d1 /SD_CDROM
/dev/dsk/c0t1t1是光驱的位置,/SD_CDROM是mount点
如果是HP-UX B.11.22以上的版本
#/usr/sbin/mount -F cdfs -o rr /
/dev/dsk/c0t1d1 /SD_CDROM
umount:
HP-UX B.11.11以下的版本
#/usr/sbin/pfs_umount /SD_CDROM
HP-UX B.11.22以上的版本
#/usr/sbin/umount /SD_CDROM
注意:临时硬盘空间
在/tmp 目录下需要最小400MB。如果在/tmp 目录下没有400MB 以上的空间,在另一个文件系统
下建立一个/tmp目录,然后设置环境变量TEMP(由Oracle使用)和TMPDIR(由操作系统程序
使用)使其指向这个位置。具体如下:
$ mkdir /data3/tmp
在.profile中增加
TEMP=/data3/tmp ; export TEMP
TMPDIR=/data3/tmp ; export TMPDIR
# /usr/sbin/groupadd oinstall
# /usr/sbin/groupadd dba
# /usr/sbin/useradd -m -g oinstall -G dba oracle
# id oracle
# passwd oracle
# mkdir -p /gh/app/oracle
# mkdir -p /ghgh/oradata
# chown -R oracle:oinstall /gh/app/oracle /ghgh/oradata
# chmod -R 775 /gh/app/oracle /ghgh/oradata
.bash_profile
#export DISPLAY= xxx.xxx.xxx.xxx
export ORACLE_TERM=vt100
export ORACLE_BASE=/gh/app/oracle
export ORACLE_HOME=$ORACLE_BASE/product/10.1.0/Db_1
export ORA_NLS33=$ORACLE_HOME/ocommon/nls/admin/data
export PATH=$PATH:$ORACLE_HOME/bin
export ORACLE_SID=ghora
export LANG=zh_CN.hp15CN
#NLS_LANG="SIMPLIFIED CHINESE_CHINA.ZHS16CGB231280"
#NLS_LANG="SIMPLIFIED CHINESE_CHINA.ZHS16GBK"
#NLS_LANG=AMERICAN_AMERICA.UTF8
#NLS_LANG="ZHS16GBK"
#export NLS_LANG
umask=022
后面的runInstaller 运行2个sh就完了
本文来自CSDN博客,转载请标明出处:http://blog.csdn.net/managergh/archive/2006/09/11/1206546.aspx