Why my program waste so much memory compare to other guys?

Run ID User Problem Result Memory Time Language Code Length Submit Time

1997342 KarlZheng 1004 Accepted 140K 0MS C++ 1781B 2007-03-14 11:10:21

1644584(2) unruliness 12K 0MS C++ 203B 2006-10-04 02:34:55

2434 00103015 20K 0MS C++ 231B 2003-03-04 14:03:06

115 farui 20K 0MS C++ 290B 2003-03-03 18:58:40

40292 Austin 20K 0MS C++ 455B 2003-09-07 22:43:44


//http://acm.pku.edu.cn/JudgeOnline/problem?id=1004
//
//Financial Management
//Time Limit:1000MS  Memory Limit:10000K
//Total Submit:21785 Accepted:10259
//
//Description
//Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
//
//Input
//The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
//
//Output
//The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
//
//Sample Input
//
//
//100.00
//489.12
//12454.12
//1234.10
//823.05
//109.20
//5.27
//1542.25
//839.18
//83.99
//1295.01
//1.75
//
//Sample Output
//
//
//$1581.42
//
//Source
//Mid-Atlantic 2001

//March 14th,20067
//Author:KarlZheng
//
#include<iostream>
//using namespace std;
int main()
{
 float fInputNumbers;
 float fResult = 0; 
 int i = 0;
 while(i<12)
 {
  std::cin >> fInputNumbers;
  fResult += fInputNumbers;
  i++;
 }
// fResult += 5;
 fResult /= 12;
 std::cout << '$' << fResult <<std::endl;
 return 0;
}
 

你可能感兴趣的:(C++,user,input,each,float,output)