HDU 1702 ACboy needs your help again!(模拟 队列 栈)

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input
   
   
   
   
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
   
   
   
   
1 2 2 1 1 2 None 2 3
 
/************************************************************************/

题意:t组例子,每组n次操作以及操作的对象(队列[FIFO] or 栈[FILO]),操作分为两种类型:①IN m:将整型数m进栈或队列;②OUT:若操作对象为队列,则输出队首元素并弹出;若操作对象是栈,则输出栈顶元素并弹出。若操作对象为空,则输出“None”

解题思路:该题比较简单,直接模拟就可以过了,不管你用数组操作,还是STL里的queue与stack都是可以的

你会你任性大笑

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<stdlib.h>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
using namespace std;
const int N = 10;
const int inf = 2147483647;
const int mod = 2009;
char s[N];
int main()
{
    int t,n,i,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%s",&n,s);
        if(s[2]=='F')
        {
            queue<int> q;
            for(i=0;i<n;i++)
            {
                scanf("%s",s);
                if(s[0]=='I')
                {
                    scanf("%d",&m);
                    q.push(m);
                }
                else
                {
                    if(q.empty())
                        puts("None");
                    else
                    {
                        printf("%d\n",q.front());
                        q.pop();
                    }
                }
            }
        }
        else
        {
            stack<int> p;
            for(i=0;i<n;i++)
            {
                scanf("%s",s);
                if(s[0]=='I')
                {
                    scanf("%d",&m);
                    p.push(m);
                }
                else
                {
                    if(p.empty())
                        puts("None");
                    else
                    {
                        printf("%d\n",p.top());
                        p.pop();
                    }
                }
            }
        }
    }
    return 0;
}
菜鸟成长记


你可能感兴趣的:(模拟,栈,队列,ACM)