POJ 2636 Electrical Outlets(我的水题之路——水,电器接头)

Electrical Outlets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7124   Accepted: 5413

Description

POJ 2636 Electrical Outlets(我的水题之路——水,电器接头)_第1张图片Roy has just moved into a new apartment. Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy's apartment has only one single wall outlet, so Roy can only power one of his electrical appliances at a time. 
Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time. The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now. 
Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered itself to be of any use.

Input

Input will start with a single integer 1 <= N <= 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 <= K <= 10, indicating the number of power strips in the test case. Then follow, on the same line, K integers separated by single spaces, O1 O2 . . . OK, where 2 <= Oi <= 10, indicating the number of outlets in each power strip.

Output

Output one line per test case, with the maximum number of appliances that can be powered.

Sample Input

3
3 2 3 4
10 4 4 4 4 4 4 4 4 4 4
4 10 10 10 10

Sample Output

7
31
37

Source

Nordic 2005

题意有点难懂,一个屋子里只有一个电源接口,现在Roy有N个外接插座,分别可以接Oi个插头,问,使用了这些插座之后,Roy一共可以外接多少个电器。

外接插座要使用也必须占用一个插座,将Oi累加,然后减去(外接插座数量N - 1)。

代码(1AC):
#include <cstdio>
#include <cstdlib>

int main(void){
    int casenum, ii;
    int sum, tmp;
    int n, i;

    scanf("%d", &casenum);
    for (ii = 0; ii < casenum; ii++){
        sum = 0;
        scanf("%d", &n);
        for (i = 0; i < n ; i++){
            scanf("%d", &tmp);
            sum += tmp;
        }
        sum -= (n - 1);
        printf("%d\n", sum);
    }
    return 0;
}


你可能感兴趣的:(Integer,System,input,each,output)