/*
http://acm.hdu.edu.cn/showproblem.php?pid=1423
Greatest Common Increasing Subsequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2724 Accepted Submission(s): 839
Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
Output
output print L - the length of the greatest common increasing subsequence of both sequences.
Sample Input
1
5
1 4 2 5 -12
4
-12 1 2 4
Sample Output
2
Source
ACM暑期集训队练习赛(二)
Recommend
lcy
解析:
题意及思路:
求最长公共上升序列
Accepted
232 KB
0 ms
C++
805 B
2013-08-03 22:50:40
*/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=500+10;
int dp[maxn],a[maxn],b[maxn];//dp[j]表示1到j中有多少个公共序列
int main()
{
int k,n,i,m,j,T;
scanf("%d",&T);
while(T--)
{ //memset(a,0,sizeof(a));
//memset(b,0,sizeof(b));
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(j=0;j<m;j++)
scanf("%d",&b[j]);
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
for(k=0,j=1;j<=m;j++)
{
if(b[j-1]<a[i-1]&&dp[j]>dp[k])k=j;
if(b[j-1]==a[i-1]&&dp[k]+1>dp[j])
{dp[j]=dp[k]+1;
//printf("%d==%d\n",j,dp[j]);
}
//printf("%d\n",dp[j]);
}
int mx=0;
for(i=0;i<=m;i++)
if(dp[i]>mx)
mx=dp[i];
printf("%d\n",mx);
if(T)
printf("\n");
}
//system("pause");
return 0;
}