Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.
Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.
Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
Input
The first line of input contains a single number T, the number of test cases to follow.
Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.
Notes and Constraints
0 < T <= 100
0 < H,W <= 100
Sample Input
2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###
Sample Output
简单深搜,就是把1241的代码稍微改下就可以了
#include <stdio.h>
#include <string.h>
char map[105][105],mat[105][105];
int vis[105][105];
void dfs(int i,int j)
{
if(vis[i][j] || mat[i][j] == '.')
return ;
vis[i][j] = 1;
dfs(i-1,j);
dfs(i,j-1);
dfs(i,j+1);
dfs(i+1,j);
}
int main()
{
int n,m,t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%*c",&n,&m);
memset(map,0,sizeof(map));
memset(mat,'.',sizeof(mat));
memset(vis,0,sizeof(vis));
int i,j,cnt = 0;
if(!m&&!n)
break;
for(i = 0;i<n;i++)
{
for(j = 0;j<m;j++)
{
scanf("%c",&map[i][j]);
mat[i+1][j+1] = map[i][j];
}
getchar();
}
for(i = 1 ;i<=n;i++)
{
for(j = 1;j<=m;j++)
{
if(!vis[i][j] && mat[i][j] == '#')
{
dfs(i,j);
cnt++;
}
}
}
printf("%d\n",cnt);
}
return 0;
}