A.Pokemon Master

Time Limit: 2 Seconds Memory Limit: 65536 KB

Calem and Serena are pokemon masters. One day they decided to have a pokemon battle practice before Pokemon World Championships. Each of them has some pokemons in each's team. To make the battle more interesting, they decided to use a special rule to determine the winner: the team with heavier total weight will win the battle!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 6), which describes that Calem has N pokemons andSerena hasM pokemons.

The second line contains N integers indicating the weight of Calem's pokemons. The third line containsM integers indicating the weight ofSerena's pokemons. All pokemons' weight are in the range of [1, 2094] pounds.

Output

For each test case, output "Calem" if Calem's team will win the battle, or "Serena" ifSerena's team will win. If the two team have the same total weight, output "Draw" instead.

Sample Input

1
6 6
13 220 199 188 269 1014
101 176 130 220 881 396

Sample Output

Serena

/*****************************************************************************************/

这是这次省赛最水的一道题目,无非就是比较两个人pokemons的总重,重的赢得比赛

#include<stdio.h>
int main()
{
    int t,i,k,n,m,sum1,sum2;
    scanf("%d",&t);
    while(t--)
    {
        sum1=sum2=0;
        scanf("%d %d",&n,&m);
        for(i=0;i<n;i++)
        {
            scanf("%d",&k);
            sum1+=k;
        }
        for(i=0;i<m;i++)
        {
            scanf("%d",&k);
            sum2+=k;
        }
        if(sum1>sum2)
            printf("Calem\n");
        else if(sum1<sum2)
            printf("Serena\n");
        else
            printf("Draw\n");
    }
    return 0;
}


你可能感兴趣的:(算法,ACM,水题)