3267 The Cow Lexicon

The Cow Lexicon
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 3615   Accepted: 1592

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

USACO 2007 February Silver

 

 

#include<cstdio>

#include<cstring>

int main()

{

    int w,l,len[610],s[310];

    char str[310],word[610][30];

    while(scanf("%d%d",&w,&l)!=EOF)

    {

        scanf("%s",str+1);

        int mm=1<<31-1;

        for(int i=1;i<=w;i++)

        {

            scanf("%s",word[i]+1);

            len[i]=strlen(word[i]+1);

            if(len[i]<mm)  mm=len[i];

        }

        s[0]=0;

        for(int i=1;i<=l;i++)

        {

            int  min=i;

            if(i<mm)

            {

                s[i]=min;

                continue;

            }

            for(int j=1;j<=w;j++)

            {

                int left=i;

                int right=len[j];

                int num=0;

                while(left>=1&&right>=1)

                {

                    if(str[left]==word[j][right])

                     {

                         left--;

                         right--;

                     }

                     else

                     {

                         left--;

                         num++;

                     }

                     if(right<=0&&min>num+s[left])   min=num+s[left];

                }

            }

            s[i]=min;

        }

        printf("%d/n",s[l]);

    }

    return 0;

}

你可能感兴趣的:(Integer,System,input,Dictionary,output,newline)