HDU1143:Tri Tiling

Problem Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.


 

Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.  
 

Output
For each test case, output one integer number giving the number of possible tilings.  
 

Sample Input
   
   
   
   
2 8 12 -1
 

Sample Output
   
   
   
   
3 153 2131
 

#include <stdio.h>

int f[50] = {0};
int i,n;

int main()
{
    f[0] = 1;
    f[2] = 3;
    for(i = 4;i<=30;i+=2)
    {
        f[i] = f[i-2]*4-f[i-4];
    }
    while(~scanf("%d",&n),n>=0)
    {
        printf("%d\n",f[n]);
    }


    return 0;
}

你可能感兴趣的:(ACM,HDU,解题报告,递推)