HDU-balloons-求颜色最多的气球的颜色

问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月19日  
*版 本 号:v1.0  
*  
*问题描述:Contest time again! How excited it is to see balloons floating around. But to 

tell you a secret, the judges' favorite time is guessing the most popular problem. When the 

contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
*程序输入:Input contains multiple test cases. Each test case starts with a number N (0 < N 

<= 1000) -- the total number of balloons distributed. The next N lines contain one color 

each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
*程序输出:For each case, print the color of balloon for the most popular problem on a 

single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

*/
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main()
{
    char a[1001][16];
    int t;
    int n,i,j,max,flag;
    while(cin>>n&&n!=0)
    {
        getchar();
        for(i=0; i<n; i++)
        {
            gets(a[i]);
        }
        max=1;
        flag=0;
        for(i=0; i<n; i++)
        {
            t=1;
            if(a[i][0]=='\0') continue;
            for(j=i+1; j<n; j++)
            {
                if(a[j][0]=='\0') continue;
                if(strcmp(a[i],a[j])==0)
                {
                    t++;
                    a[j][0]='\0';
                }
            }
            if(t>max)
            {
                max=t;
                flag=i;
            }
        }
        puts(a[flag]);
    }
    return 0;
}



运行结果:


HDU-balloons-求颜色最多的气球的颜色_第1张图片

知识点总结:
求颜色最多的气球的颜色。

学习心得:

二维数组。。。这就能用上了。。

你可能感兴趣的:(C++,二维数组)