hdoj 3665 Seaside 【裸最短路】

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1295    Accepted Submission(s): 947


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
       
       
       
       
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
       
       
       
       
2
 



题意:有N个点(编号从0-N-1),有若干个点距离海较近。现在你从0点出发,问你到达海边的最短路。



距离那些海边的点,然后就是最短路裸题,不解释。


#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define MAXN 200
#define MAXM 400
#define INF 0x3f3f3f
using namespace std;
struct Edge
{
    int from, to, val, next;
};
Edge edge[MAXM];
int head[MAXN], edgenum;
int dist[MAXN];
bool vis[MAXN];
int N;
void init()
{
    edgenum = 0;
    memset(head, -1, sizeof(head));
}
void addEdge(int u, int v, int w)
{
    Edge E = {u, v, w, head[u]};
    edge[edgenum] = E;
    head[u] = edgenum++;
}
int top;
int rec[MAXN];//记录海边的点
void getMap()
{
    int x, y, c, num, op;
    top = 0;
    for(int i = 0; i < N; i++)
    {
        scanf("%d%d", &num, &op);
        if(op == 1)
            rec[top++] = i;
        while(num--)
        {
            scanf("%d%d", &y, &c);
            addEdge(i, y, c);
            addEdge(y, i, c);
        }
    }
}
void SPFA(int sx)
{
    queue<int> Q;
    memset(dist, INF, sizeof(dist));
    memset(vis, false, sizeof(vis));
    dist[sx] = 0;
    vis[sx] = true;
    Q.push(sx);
    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        for(int i = head[u]; i != -1; i = edge[i].next)
        {
            Edge E = edge[i];
            if(dist[E.to] > dist[u] + E.val)
            {
                dist[E.to] = dist[u] + E.val;
                if(!vis[E.to])
                {
                    vis[E.to] = true;
                    Q.push(E.to);
                }
            }
        }
    }
    int ans = INF;
    for(int i = 0; i < top; i++)
        ans = min(ans, dist[rec[i]]);
    printf("%d\n", ans);
}
int main()
{
    while(scanf("%d", &N) != EOF)
    {
        init();
        getMap();
        SPFA(0);
    }
    return 0;
}


你可能感兴趣的:(hdoj 3665 Seaside 【裸最短路】)