[模拟]uva993 Product of digits



  Product of digits 

For a given non-negative integer number N , find the minimal natural Q such that the product of all digits of Q is equal N .

Input 

The first line of input contains one positive integer number, which is the number of data sets. Each subsequent line contains one data set which consists of one non-negative integer number N (0N109) .

Output 

For each data set, write one line containing the corresponding natural number Q or `-1' if Q does not exist.

Sample Input 

3 
1 
10 
123456789

Sample Output 

1 
25 
-1



题意:给你一个大于等于0 的整数N,请你你找到最小的自然数Q ,使得在Q 中所有数字(digit)的乘积等于N 。

思路:比较简单了,就是判断这个数能否被分解成一串1-9的数字相乘得到。

#include<iostream>
#include<string>

using namespace std;

int main()
{
    int num;
    cin>>num;
    while(num--)
    {
        int n;
        cin>>n;
        if(n==0||n==1)
        {
            cout<<n<<endl;
            continue;
        }
        string str="";
        for(int i=9;i>=2;i--)
        {
            while(n%i==0)
            {
                char ch=('0'+i);
                str=str+ch;
                n=n/i;
            }
        }
        if(n!=1) cout<<"-1"<<endl;
        else
        {
            for(int i=str.size()-1;i>=0;i--)
                cout<<str[i];
            cout<<endl;
        }
    }
    return 0;
}

你可能感兴趣的:(模拟)