杭电1719 简单数学题

       这道题经过推导之后可以得到n=2^x*3^y-1,凡是形如这样的数都是friend数,,之后程序就简单了,需要注意的是0不是friend数。。。。题目:

Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 998    Accepted Submission(s): 481


Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
   
   
   
   
3 13121 12131
 

Sample Output
   
   
   
   
YES! YES! NO!
 

ac代码:

#include <stdio.h>
int main(){
  int x;
  while(~scanf("%d",&x)){
	  if(!x){printf("NO!\n");continue;}
	  x++;
	  while(x%2==0){
	    x/=2;
	  }
	  while(x%3==0)
		  x/=3;
	  if(x!=1)
		  printf("NO!\n");
	  else
		  printf("YES!\n");
  }
  return 0;
}


你可能感兴趣的:(杭电1719 简单数学题)