[回溯]Graph Coloring UVA193



 Graph Coloring 

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

   
Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers  ,  , and a set of undirected edges denoted by pairs of node numbers  ,  . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5


这道题需要换一个思路去解题,设想一开始所有的结点都是白色,我们负责把结点染黑就可以,然后回溯求解,在这个基础上再剪枝,这样下来就方便很多,比分别染黑染白要简单很多。

#include<iostream>
#include<cstring>

using namespace std;

int maxnum,n;
int color[110],black[110],grid[110][110];

void dfs(int pos,int num)
{
    int i,tag=1;
    if(num>maxnum)
    {
        maxnum=num;
        for(i=1;i<=n;i++)
        {
            black[i]=color[i];
        }
    }
    if(num+n-pos+1<=maxnum) return;
    for(i=1;i<=n;i++)
    {
        if(grid[i][pos]==1&&color[i]==1)
        {
            tag=0;
            break;
        }
    }
    if(tag)
    {
        color[pos]=1;
        dfs(pos+1,num+1);
        color[pos]=0;
    }
    dfs(pos+1,num);
    return;
}

int main()
{
    int t,m;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        int i,j,x,y;
        memset(grid,0,sizeof(grid));
        memset(color,0,sizeof(color));
        for(i=1;i<=m;i++)
        {
            cin>>x>>y;
            grid[x][y]=grid[y][x]=1;
        }
        maxnum=0;
        dfs(1,0);
        cout<<maxnum<<endl;
        int s=0;
        for(i=1;i<=n;i++)
        {
            if(black[i])
            {
                s++;
                cout<<i;
                if(s==maxnum)
                {
                    cout<<endl;
                }
                else
                {
                    cout<<" ";
                }
            }
        }
    }
    return 0;
}

你可能感兴趣的:(搜索,回溯)