[哈希]PAT1032 Sharing

1032. Sharing (25)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

题意:给出了存储两个字符串的字符的存储内存区的首尾地址,求两个字符串的公共存储区的首地址。

思路:这道题据说是12年研究生考试时数据结构的大题。我是使用哈希来做的。

#include<iostream>
#include<iomanip>

using namespace std;

int arry1[100005],arry2[100005];

int main()
{
    int pos1,pos2,len;
    cin>>pos1>>pos2>>len;
    int i,j,k;
    char ch;
    for(i=0;i<len;i++)
    {
        cin>>j>>ch>>k;
        arry1[j]=k;
    }
    while(pos1!=-1)
    {
        arry2[pos1]=1;
        pos1=arry1[pos1];
    }
    int tag=0;
    while(pos2!=-1)
    {
        if(arry2[pos2]==1)
        {
            tag=1;
            k=pos2;
            break;
        }
        pos2=arry1[pos2];
    }
    if(tag) cout<<setfill('0')<<setw(5)<<k<<endl;
    else cout<<"-1"<<endl;
    return 0;
}


你可能感兴趣的:(hash)