Osu!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1277 Accepted Submission(s): 669
Special Judge
Problem Description
Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.
Now, you want to write an algorithm to estimate how diffecult a game is.
To simplify the things, in a game consisting of N points, point i will occur at time t
i at place (x
i, y
i), and you should click it exactly at t
i at (x
i, y
i). That means you should move your cursor from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between t
i and t
i+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game.
Now, given a description of a game, please calculate its difficulty.
Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.
For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game. Then N lines follow, the i-th line consisting of 3 space-separated integers, t
i(0 ≤ t
i < t
i+1 ≤ 10
6), x
i, and y
i (0 ≤ x
i, y
i ≤ 10
6) as mentioned above.
Output
For each test case, output the answer in one line.
Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
Sample Input
2
5
2 1 9
3 7 2
5 9 0
6 6 3
7 6 0
10
11 35 67
23 2 29
29 58 22
30 67 69
36 56 93
62 42 11
67 73 29
68 19 21
72 37 84
82 24 98
Sample Output
9.2195444573
54.5893762558
Hint
In memory of the best osu! player ever Cookiezi.
签到题,重点在这里
This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between t
i and t
i+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game.
AC代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;
struct Point
{
double x, y, t;
};
Point num[1010], c1, c2;
double rec[1000010];
double work(int c1, int c2)
{
return sqrt((num[c1].x - num[c2].x) * (num[c1].x - num[c2].x) + (num[c1].y - num[c2].y) * (num[c1].y - num[c2].y)) / (num[c1].t - num[c2].t);
}
int main()
{
int t;
int N;
scanf("%d", &t);
while(t--)
{
scanf("%d", &N);
for(int i = 0; i < N; i++)
scanf("%lf%lf%lf", &num[i].t, &num[i].x, &num[i].y);
int k = 0;
for(int i = 0; i < N-1; i++)
rec[k++] = work(i+1, i);
sort(rec, rec + k);
printf("%.10lf\n", rec[k-1]);
}
return 0;
}