F(x)
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 606 Accepted Submission(s): 236
Problem Description
For a decimal number x with n digits (A
nA
n-1A
n-2 ... A
2A
1), we define its weight as F(x) = A
n * 2
n-1 + A
n-1 * 2
n-2 + ... + A
2 * 2 + A
1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10
9)
Output
For every case,you should output "Case #t: " at first, without quotes. The
t is the case number starting from 1. Then output the answer.
Sample Input
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13
Source
2013 ACM/ICPC Asia Regional Chengdu Online
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;
const int MAX=10;
int dp[MAX][5000];//表示剩余i位最大可加j时的方法数
int a,b,pow[MAX][MAX];//pow表示j*2^i
int digit[MAX];
void Init(){
memset(dp,-1,sizeof dp);
for(int i=1;i<MAX;++i)pow[i][0]=i;
for(int i=1;i<MAX;++i){
for(int j=1;j<MAX;++j)pow[j][i]=pow[j][i-1]*2;
}
}
int digit_dp(int k,int size,int flag){
if(!flag && dp[size][k] != -1)return dp[size][k];
if(!size)return 1;
int m=flag?digit[size]:9,sum=0;
for(int i=0;i<=m;++i){
if(pow[i][size-1]>k)break;
sum+=digit_dp(k-pow[i][size-1],size-1,flag && i == digit[size]);
}
if(!flag)dp[size][k]=sum;
return sum;
}
int calculate(int &b,int &a){
int n=0,size=0;
while(a)n+=pow[a%10][size++],a/=10;
a=n,size=0;
while(b)digit[++size]=b%10,b/=10;
return digit_dp(a,size,1);
}
int main(){
Init();
int t,num=0;
scanf("%d",&t);
while(t--){
scanf("%d%d",&a,&b);
printf("Case #%d: %d\n",++num,calculate(b,a));
}
return 0;
}