杭电OJ ——1009——FatMouse' Trade

FatMouse' Trade

                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)



Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
   
   
   
   
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
   
   
   
   
13.333 31.500
 

Author
CHEN, Yue
 

Source
ZJCPC2004
 

Recommend
JGShining

#include<iostream>
#include<cstdio>
using namespace std; typedef struct { int bnum; int cnum; double flag; }kinds; void bubblesort(kinds a[],int n) { int i,j;
    kinds t; for(i=1;i<n;i++) for(j=0;j<n-i;j++) if(a[j].flag<a[j+1].flag) {
                t=a[j];
                a[j]=a[j+1];
                a[j+1]=t; } } int main() { int fnum,rnum;
    kinds a[1002]; while(cin>>fnum>>rnum && (fnum!=-1 && rnum!=-1)) { double sum=0; for(int i=0;i<rnum;i++) {
             cin>>a[i].bnum>>a[i].cnum;
             a[i].flag=a[i].bnum*1.0/a[i].cnum; }
         bubblesort(a,rnum); for(i=0;i<rnum;i++)//好贱的题目,丢了一个i<rnum,居然wa
 {//不过也实在太粗心了,有可能食物太充足,导致所有房间的豆子都换完了,还有剩,自然会出错!
 if(fnum>=a[i].cnum) {
                 sum=sum+a[i].bnum;
                fnum=fnum-a[i].cnum; } else {
                 sum=sum+1.0*fnum/a[i].cnum*a[i].bnum; break; } }
         printf("%.3lf\n",sum); } return 0; }
/***************************
在这个程序里,感受最多的是,自动类型转换,这个东西很好用!
int s;
double sum;
sum=1+1.0*s;//这里发生了自动转换 1.0*s为double型了!
*****************************/


你可能感兴趣的:(struct,homework,input,each,javabeans,output)