2386.Lack Counting -POJ

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16090   Accepted: 8148

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
推荐指数:※※
来源: http://poj.org/problem?id=2386
DFS,估计测试集比较小,都不要剪枝。。
#include<iostream>
#include<string.h>
using namespace std;
#define N 101
char square[N][N];
bool visited[N][N];
int n,m;
int adj[8][2]={{-1,-1},{-1,0},{-1,1},
				{0,-1},{0,1},
				{1,-1},{1,0},{1,1}};
bool is_ok(int i,int j){
	return (i>=1&&i<=n&&j>=1&&j<=m);
}
bool dfs(int now_i,int now_j)
{
	int i;
	if(visited[now_i][now_j]==true||square[now_i][now_j]=='.'||is_ok(now_i,now_j)==false)
		return false;
	visited[now_i][now_j]=true;
	for(i=0;i<8;i++){
		int tmp_i=now_i+adj[i][0];
		int tmp_j=now_j+adj[i][1];
		dfs(tmp_i,tmp_j);
	}
}
int main()
{
	int i,j;
	cin>>n>>m;
	for(i=1;i<=n;i++){
		for(j=1;j<=m;j++){
			cin>>square[i][j];
		}
	}
	int ponds=0;
	memset(visited,0,sizeof(visited));
	for(i=1;i<=n;i++){
		for(j=1;j<=m;j++){
			if(square[i][j]=='W'&&visited[i][j]==false){
				dfs(i,j);
				ponds++;
			}
		}
	}
	cout<<ponds<<endl;
	return 0;
}


你可能感兴趣的:(2386.Lack Counting -POJ)