HDOJ Stars 1541(树状数组)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5677    Accepted Submission(s): 2247


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

HDOJ Stars 1541(树状数组)_第1张图片

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
   
   
   
   
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
   
   
   
   
1 2 1 1 0
 

Source
Ural Collegiate Programming Contest 1999
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1394  3450  1542  1255  1540 

需要注意的是树状数组下标从1开始,题目中数据可以从0开始,所以需要将x写为x+1~

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define maxn 32010
using namespace std;
int bit[maxn];
int level[maxn];
int lowbit(int x){
	return x&-x;
}
void update(int x,int num)
{
	while(x<=maxn){
		bit[x]+=num;
		x+=lowbit(x);
	}
}
int sum(int x)
{
	int s=0;
	while(x>0){
		s+=bit[x];
		x-=lowbit(x);
	}
	return s;
}
int main()
{
	int N;
	while(scanf("%d",&N)!=EOF){
		memset(bit,0,sizeof(bit));
		memset(level,0,sizeof(level));
		int x,y;
		for(int i=1;i<=N;i++){
			scanf("%d%d",&x,&y);
			level[sum(x+1)]++;
			update(x+1,1);
		}
		for(int i=0;i<N;i++){
			printf("%d\n",level[i]);
		}
	}
	return 0;
}


你可能感兴趣的:(HDOJ Stars 1541(树状数组))