The Bottom of a Graph
Time Limit: 3000MS |
|
Memory Limit: 65536K |
Total Submissions: 5383 |
|
Accepted: 2197 |
Description
We will use the following (standard) definitions from graph theory. Let
V be a nonempty and finite set, its elements being called vertices (or nodes). Let
E be a subset of the Cartesian product
V×V, its elements being called edges. Then
G=(V,E) is called a directed graph.
Let
n be a positive integer, and let
p=(e1,...,en) be a sequence of length
n of edges
ei∈E such that
ei=(vi,vi+1) for a sequence of vertices
(v1,...,vn+1). Then
pis called a path from vertex
v1 to vertex
vn+1 in
G and we say that
vn+1 is reachable from
v1, writing
(v1→vn+1).
Here are some new definitions. A node
v in a graph
G=(V,E) is called a sink, if for every node
w in
G that is reachable from
v,
v is also reachable from
w. The bottom of a graph is the subset of all nodes that are sinks, i.e.,
bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.
Input
The input contains several test cases, each of which corresponds to a directed graph
G. Each test case starts with an integer number
v, denoting the number of vertices of
G=(V,E), where the vertices will be identified by the integer numbers in the set
V={1,...,v}. You may assume that
1<=v<=5000. That is followed by a non-negative integer
e and, thereafter,
e pairs of vertex identifiers
v1,w1,...,ve,we with the meaning that
(vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.
Output
For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.
Sample Input
3 3
1 3 2 3 3 1
2 1
1 2
0
Sample Output
1 3
2
Source
Ulm Local 2003
题目: http://poj.org/problem?id=2553
分析:这题也是很普通的强连通分量,跟上一题类似,不过没给出边的条数,最好用链表,我懒得写了。。。不过这题貌似50000左右的边,呵呵,之前不知道为什么wa了好多次,囧
代码:
#include<cstdio>
#define min(a,b) a<b?a:b
using namespace std;
const int mm=50005;
const int mn=5005;
int t[mm],p[mm];
int h[mn],id[mn],q[mn],dfn[mn],low[mn];
int i,j,k,n,m,tsp,qe,cnt;
void dfs(int u)
{
int i,v;
dfn[u]=low[q[qe++]=u]=++tsp;
for(i=h[u];i>=0;i=p[i])
if(!dfn[v=t[i]])
dfs(v),low[u]=min(low[u],low[v]);
else if(id[v]<0&&low[u]>dfn[v])low[u]=dfn[v];
if(low[u]==dfn[u])
{
id[u]=++cnt;
while((v=q[--qe])!=u)id[v]=cnt;
}
}
void tarjan()
{
int i;
for(tsp=qe=cnt=i=0;i<=n;++i)id[i]=-1,dfn[i]=0;
for(i=1;i<=n;++i)
if(!dfn[i])dfs(i);
}
int main()
{
while(scanf("%d",&n),n)
{
scanf("%d",&m);
for(i=0;i<=n;++i)h[i]=-1;
for(k=0;k<m;++k)
{
scanf("%d%d",&i,&j);
t[k]=j,p[k]=h[i],h[i]=k;
}
tarjan();
for(i=0;i<=cnt;++i)q[i]=0;
for(i=1;i<=n;++i)
if(!q[id[i]])
for(j=h[i];j>=0;j=p[j])
if(id[i]!=id[t[j]])
{
++q[id[i]];
break;
}
for(i=1;i<=n;++i)
if(!q[id[i]])printf("%d ",i);
printf("\n");
}
return 0;
}