The Water Problem
Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 207 Accepted Submission(s): 166
Problem Description
Input
First you are given an integer
T(T≤10) indicating the number of test cases. For each test case, there is a number
n(0≤n≤1000) on a line representing the number of water sources.
n integers follow, respectively
a1,a2,a3,...,an , and each integer is in
{1,...,106} . On the next line, there is a number
q(0≤q≤1000) representing the number of queries. After that, there will be
q lines with two integers
l and
r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.
Output
For each query, output an integer representing the size of the biggest water source.
Sample Input
3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3
Sample Output
100
2
3
4
4
5
1
999999
999999
1
Source
2015 ACM/ICPC Asia Regional Changchun Online
题意:给出n个水池的水量,找出区间内最大的水量。
分析:咋一看觉得是线段树,后面一看数据范围,才10*1000*100嘛,果断暴力。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))
int a[1005];
int n,q,l,r;
int main ()
{
int T;
scanf ("%d",&T);
while (T--)
{
scanf ("%d",&n);
for (int i=1; i<=n; i++)
scanf ("%d",&a[i]);
scanf ("%d",&q);
int maxx;
while (q--)
{
maxx=0;
scanf ("%d%d",&l,&r);
for (int i=l; i<=r; i++)
maxx=max(maxx, a[i]);
cout<<maxx<<endl;
}
}
}