Exam
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 756 Accepted Submission(s): 384
Problem Description
As this term is going to end, DRD needs to prepare for his final exams.
DRD has
n exams. They are all hard, but their difficulties are different. DRD will spend at least
ri hours on the
i -th course before its exam starts, or he will fail it. The
i -th course's exam will take place
ei hours later from now, and it will last for
li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.
So he wonder whether he can pass all of his courses.
No two exams will collide.
Input
Output
For each test case: output ''Case #x: ans'' (without quotes), where
x is the number of test cases, and
ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).
Sample Input
2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2
7 1000 2
Sample Output
Source
The 2015 ACM-ICPC China Shanghai Metropolitan Programming Contest
题意:DRD有n们课程,每次输入三个数分别表示该们课需要复习的时间、考试开始的时间、考试执行的时间。
分析:刚一看题就觉得是贪心,立马就写了,然而WA了三次,着实不解哪里有错,然后看到一片博客,我就呵呵了,就是一大水题,然而题意没说清楚;题目并没有说可以多门课程一起复习,然而这么写却是可以过的。我也真是无力吐槽了。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))
struct node
{
ll r,e,l;
}s[100005];
ll cmp(node a, node b)
{
return a.e<b.e;
}
int main ()
{
int T,n,ii=1;
scanf ("%d",&T);
while (T--)
{
scanf ("%d",&n);
bool flag=false;
for (int i=0; i<n; i++)
{
scanf ("%lld%lld%lld",&s[i].r,&s[i].e,&s[i].l);
if (s[i].r > s[i].e)//直接判断是否有需要复习时间在考试开始时间之后就行
{
flag = true;
}
}
/*sort(s, s+n, cmp);//这是我之前的WA代码
ll sum=0;
for (int i=0; i<n; i++)
{
if (s[i].e<sum+s[i].r || s[i].r>s[i].e)
{
flag = true;
break;
}
else sum += (s[i].r+s[i].e+s[i].l);
}*/
printf ("Case #%d: ",ii++);
if (flag)
printf ("NO\n");
else
printf ("YES\n");
}
return 0;
}