1069. The Black Hole of Numbers (20)纯模拟题,然跟

1069. The Black Hole of Numbers (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
# include <cstdio>
# include <iostream>
# include <cstring>
# include <cstdlib>
# include <stack>
# include <queue>
using namespace std;

int cmp1(const void *p1,const void *p2)
{
    return  (*(int*)p1 - *(int*)p2);
}
int cmp2(const void *p1,const void *p2)
{
    return -(*(int*)p1 - *(int*)p2);
}
int GetNumber(int *Number,int Lenth)
{
    int ret = 0;
    for (int i=0;i<Lenth;i++)
    {
        ret = Number[i] + 10*ret;
    }
    return ret;
}
int num[4];
int main()
{
    int n;
    scanf("%d",&n);
    do
    {
        int n1,n2;
        for (int i=0;i<4;i++)
        {
            num[i] = n%10;
            n /= 10;
        }
        qsort(num,4,sizeof(int),cmp1);
        n1 = GetNumber(num,4);
        qsort(num,4,sizeof(int),cmp2);
        n2 = GetNumber(num,4);
        n = n2 - n1;
        printf("%04d - %04d = %04d\n",n2,n1,n);
    }while (n!=6174&&n!=0);
    return 0;
}
1069. The Black Hole of Numbers (20)纯模拟题,然跟_第1张图片

你可能感兴趣的:(编程,模拟,水题,pat)