1048. Find Coins (25)

1048. Find Coins (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution
    这道题是一道枚举题,虽然水,但是暴力尝试所有可能,也是过不了的,真的要过,需要用到一点技巧,其实两枚硬币我们只需要枚举一枚就够了,在输入时开一个Count数组记录每个硬币出现的次数,如果一枚硬币是i,再检查Count[m-i]数组即可,值得注意的是,m-i有可能越界,也有可能等于i,我的处理方式是在循环的时候限定i<=m-i,同时在对每个例子进行分析的时候,cnt[i]--,cnt[m-i]--,然后检查是否两者都大于0。当然,真正做题的时候我错了几次。
# include <cstdio>

int cnt[5005];  /*其实开3005就够了*/
int main()
{
  int i,j,temp;
  int n,m;
  scanf("%d%d",&n,&m);
  for (i=0;i<n;i++)
    {
      scanf("%d",&temp);
      cnt[temp]++; 
    }
  for (i=1;i<=m-i;i++)/*这里要注意i循环从1开始,因为要交出两枚硬币*/ 
    {
   	  cnt[i]--;cnt[m-i]--;
	  if (cnt[i]>=0&&cnt[m-i]>=0)
	      break;
	}
  if (i<=m-i)
    printf("%d %d\n",i,m-i);
  else 
    printf("No Solution\n");
  return 0;
}


你可能感兴趣的:(枚举,编程,pat)