点击打开链接
Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.
Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.
Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
Input
The first line of input contains a single number T, the number of test cases to follow.
Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.
Notes and Constraints
0 < T <= 100
0 < H,W <= 100
Sample Input
2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###
Sample Output
#include<stdio.h>
#include<string.h>
char aa[200][200];
int visit[105][105],w,h;
int s[4][2]={{1, 0}, {0, -1}, { -1, 0}, {0, 1}};
int DFS(int a,int b)
{
int i,x,y;
for(i=0;i<4;i++)
{
x=a+s[i][0];
y=b+s[i][1];
if(visit[x][y]==0&&x>=0&&x<h&&y>=0&&y<w&&aa[x][y]=='#')
{
visit[x][y]=1;
DFS(x,y);
}
}
}
int main()
{
int t,i,j,c,d,count;
scanf("%d",&t);
while(t--)
{
count=0;
memset(visit,0,sizeof(visit));
scanf("%d %d",&h,&w);
getchar();
for(i=0;i<h;i++)
gets(aa[i]);
for(i=0;i<h;i++)
for(j=0;j<w;j++)
{
if(aa[i][j]=='#'&&visit[i][j]==0)
{
visit[i][j]=1;
DFS(i,j);
count++;
}
}
printf("%d\n",count);
}
return 0;
}