hdu 5635 LCP Array(BC第一题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5635

LCP Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 282    Accepted Submission(s): 79


Problem Description
Peter has a string  s=s1s2...sn , let  suffi=sisi+1...sn  be the suffix start with  i -th character of  s . Peter knows the lcp (longest common prefix) of each two adjacent suffixes which denotes as  ai=lcp(suffi,suffi+1)(1i<n ).

Given the lcp array, Peter wants to know how many strings containing lowercase English letters only will satisfy the lcp array. The answer may be too large, just print it modulo  109+7 .
 

Input
There are multiple test cases. The first line of input contains an integer  T  indicating the number of test cases. For each test case:

The first line contains an integer  n  ( 2n105)  -- the length of the string. The second line contains  n1  integers:  a1,a2,...,an1   (0ain) .

The sum of values of  n  in all test cases doesn't exceed  106 .
 

Output
For each test case output one integer denoting the answer. The answer must be printed modulo  109+7 .
 

Sample Input
   
   
   
   
3 3 0 0 4 3 2 1 3 1 2
 

Sample Output
   
   
   
   
16250 26 0
 

Source
BestCoder Round #74 (div.2)  

题目大意:先输入一个t代表着测试组数,再输入一个n表示字符串的长度,s1,s2,s2,s2.......接下去输入n-1个数,表示的最长相同前缀的长度。

即:以第二组测试数据为例

hdu 5635 LCP Array(BC第一题)_第1张图片 ai=lcp(suffi,suffi+1);

解题思路:经过分析找到:a[i-1]=a[i]+1;如果一直满足这个条件的话,直接输出26,不满足直接输出0。

需要注意的是:最后一个数a[n-1]一定要大于1,否则直接输出0。还有一个就是第一数a[1]等于0的话,直接乘26,之后遇到0就乘25。


详见代码。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

__int64 a[100010],s;
const int Mod=(1e9+7);

int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n;
        scanf("%d",&n);
        for (int i=1; i<=n-1; i++)
        {
            scanf ("%I64d",&a[i]);
        }
        int flag=0;
        s=1;
        int k=0;
        for (int i=1; i<n; i++)
        {
            if (i==1)
            {
                if (a[i]==0)
                {
                    s=(s*26)%Mod;
                    k=1;
                }
                continue;
            }
            if (a[i-1]>0&&a[i-1]!=a[i]+1)
                flag=1;
            else
            {
                if (a[i]==0)
                {
                    if (k==1)
                        s=(s*25)%Mod;
                    else
                    {
                        s=(s*26)%Mod;
                        k=1;
                    }
                }
            }
        }
        if (k==1)
            s=(s*25)%Mod;
        else
            s=(s*26)%Mod;
        if (flag==1||a[n-1]>1)
            printf ("0\n");
        else
            printf ("%I64d\n",s);
    }
    return 0;
}



ai=lcp(suffi,suffi+1)

你可能感兴趣的:(C语言)