杭电1003 Max Sum



Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 183237    Accepted Submission(s): 42745


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
        
        
        
        
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

Sample Output
        
        
        
        
Case 1:
14 1 4
7 1 6
Case 2:
 

Author
Ignatius.L

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1003


注意考虑数据全为负数的情况!!!!


#include <stdio.h>
int main()
{
    int t,n,i;
    int a[100000];
    int sum,max,start,end,s,e;
    int id=0,flag=0,fu;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        fu=0;
        for (i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if (a[i]<0)
            {
                fu++;
            }
        }
        if (flag)
        {
            printf("\n");
        }
        flag=1;
        printf("Case %d:\n",++id);

        if (fu==n)//全为负
        {
            max=a[0];
            s=0;
            for(i=1; i<n; i++)
            {
                if (a[i]>max)
                {
                    max=a[i];
                    s=i;
                }
            }
            printf("%d %d %d\n",max,s+1, s+1);
            continue;
        }
        sum=start=end=s=e=0;
        max=-1000;
        for (i=0; i<n; i++)
        {
            sum+=a[i];
            if (sum>=0)
            {
                end=i;
            }
            else /**(sum<0)**/
            {
                sum=0;
                start=i+1;
                end=i+1;
            }
            if (sum>=max)
            {
                max=sum;
                s=start;
                e=end;
            }
        }
        printf("%d %d %d\n",max,s+1,e+1);
    }
    return 0;
}





你可能感兴趣的:(ACM,HDU,杭电,1005)