HDU1094A+B for Input-Output Practice (VI)(入门题,C,Java两个版本)

A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60613    Accepted Submission(s): 40750


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.
 

Output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.
 

Sample Input
   
   
   
   
4 1 2 3 4 5 1 2 3 4 5
 

Sample Output
   
   
   
   
10 15
 

Author
lcy

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1094

C语言AC代码:
#include <stdio.h>
int main()
{
    int n,x,sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        while(n--)
        {
            scanf("%d",&x);
            sum+=x;
        }
        printf("%d\n",sum);
    }
    return 0;
}



Java AC代码:
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int n = sc.nextInt();
			
			int sum = 0;
			while(n-->0){
				int x =sc.nextInt();
				sum += x;
			}
			System.out.println(sum);
		}
	}

}


你可能感兴趣的:(java,HDU1094)