HDU1089-1092A+B for Input-Output Practice(入门题C,Java两个版本)

1089 A+B for Input-Output Practice (I)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 113308    Accepted Submission(s): 61772


Problem Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 

Sample Input
   
   
   
   
1 5 10 20
 

Sample Output
   
   
   
   
6 30
 

Author
lcy

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1089

C语言AC代码:
#include <stdio.h>
int main()
{
    int a,b;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        printf("%d\n",a+b);
    }
    return 0;
}

Java AC代码:
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int a = sc.nextInt();
            int b = sc.nextInt();
            System.out.println(a+b);
        }
    }

}

1090 A+B for Input-Output Practice (II)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 85260    Accepted Submission(s): 54785


Problem Description
Your task is to Calculate a + b.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 

Sample Input
    
    
    
    
2 1 5 10 20
 

Sample Output
    
    
    
    
6 30
 

Author
lcy

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1090


C语言AC代码
#include <stdio.h>
int main()
{
    int n,a,b;
    scanf("%d",&n);
    while (n--)
    {
        scanf("%d %d",&a,&b);
        printf("%d\n",a+b);
    }

    return 0;
}

Java AC代码:
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		while(n-->0){
			int a = sc.nextInt();
			int b = sc.nextInt();
			System.out.println(a+b);
		}
	}

}


1091 A+B for Input-Output Practice (III)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 95396    Accepted Submission(s): 50079


Problem Description
Your task is to Calculate a + b.
 

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 

Sample Input
    
    
    
    
1 5 10 20 0 0
 

Sample Output
    
    
    
    
6 30
 

Author
lcy

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1091

C语言AC代码:
#include <stdio.h>
int main()
{
    int a,b;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        if (a==0&&b==0) break;
        printf("%d\n",a+b);
    }
    return 0;
}

Java AC代码:
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int a = sc.nextInt();
			int b = sc.nextInt();
			if(a==0&&b==0) break;
			System.out.println(a+b);
		}

	}

}

1092 A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 87444    Accepted Submission(s): 46364


Problem Description
Your task is to Calculate the sum of some integers.
 

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 

Sample Input
     
     
     
     
4 1 2 3 4 5 1 2 3 4 5 0
 

Sample Output
     
     
     
     
10 15
 

Author
lcy


原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1092

C语言AC代码:
#include <stdio.h>
int main()
{
    int n,m,sum;
    while(scanf("%d",&n)!=EOF&&n)
    {
        sum=0;
        while(n--)
        {
            scanf("%d",&m);
            sum+=m;
        }
        printf("%d\n",sum);
    }
    return 0;
}


Java AC代码:

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int n = sc.nextInt();
			if(n == 0 ){
				break;
			}
			int sum = 0;
			while(n-->0){
				int x = sc.nextInt();
				sum += x;
			}
			System.out.println(sum);
		}
	}

}





你可能感兴趣的:(HDU1090,HDU1089,HDU1)