UVa 264 Count on Cantor

Count on Cantor

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to  and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

The input list contains a single number per line and will be terminated by end-of-file.

Sample input

3
14
7

Sample output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4


这个简单的题我几乎把所有的数都试过了,而且中间也改了不少错了,可是还是WA,无奈去网上学习他人经验,发现一个比较高效的解法,


AC代码:

#include <stdio.h>
#include <math.h>

int main(int argc, const char * argv[]) {
    int input;
    int m;
    
    while (scanf("%d", &input) == 1) {
        printf("TERM %d IS ", input);
        m = (1 + sqrt(8 * input - 7)) / 2;
        input -= m * (m + 1) / 2;
        if (m % 2) {
            printf("%d/%d\n",1 - input, input + m);
        } else {
            printf("%d/%d\n", input + m, 1 - input);
        }
    }
    
    return 0;
    
}


你可能感兴趣的:(数学,ACM,uva)