hdu 1561 The more, The Better(树形dp)

1、http://acm.hdu.edu.cn/showproblem.php?pid=1561

2、题目大意:

ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物。但由于地理位置原因,有些城堡不能直接攻克,要攻克这些城堡必须先攻克其他某一个特定的城堡。你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗?


 

Input
每个测试实例首先包括2个整数,N,M.(1 <= M <= N <= 200);在接下来的N行里,每行包括2个整数,a,b. 在第 i 行,a 代表要攻克第 i 个城堡必须先攻克第 a 个城堡,如果 a = 0 则代表可以直接攻克第 i 个城堡。b 代表第 i 个城堡的宝物数量, b >= 0。当N = 0, M = 0输入结束。


 

Output
对于每个测试实例,输出一个整数,代表ACboy攻克M个城堡所获得的最多宝物的数量。


 

Sample Input
   
   
   
   
3 2 0 1 0 2 0 3 7 4 2 2 0 1 0 4 2 1 7 1 7 6 2 2 0 0


 

Sample Output
   
   
   
   
5 13

 

3、代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int v[210];
int dp[210][210];
int son[210];//存子节点
int head[210];
int dfs(int root)
{
    dp[root][1]=v[root];
    int tot=1;
    for(int i=son[root];i!=-1;i=head[i])
    {
        tot+=dfs(i);//剪枝,每次只用循环到当前能达到的最大值。
        for(int j=tot;j>=1;j--)
        {
            for(int k=1;k+j<=tot+1;k++)
            {
                dp[root][j+k]=max(dp[root][j+k],dp[root][j]+dp[i][k]);
            }
        }
    }
    return tot;
}

int main()
{
    int n,m,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        break;
        memset(dp,0,sizeof(dp));
        memset(son,-1,sizeof(son));
        memset(v,0,sizeof(v));
        v[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&j,&v[i]);
            head[i]=son[j];
            son[j]=i;//j的儿子是i
        }
        dfs(0);
        printf("%d\n",dp[0][m+1]);
    }
    return 0;
}
/*
3 2
0 1
0 2
0 3
7 4
2 2
0 1
0 4
2 1
7 1
7 6
2 2
0 0
*/


 

你可能感兴趣的:(hdu 1561 The more, The Better(树形dp))