hdu 5373 The shortest problem 2015多校联合训练赛#7 模拟

The shortest problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 532    Accepted Submission(s): 271


Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
 

Input
Multiple input.
We have two integer n (0<=n<= 104  ) , t(0<=t<= 105 ) in each row.
When n==-1 and t==-1 mean the end of input.
 

Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
 

Sample Input
   
   
   
   
35 2 35 1 -1 -1
 

Sample Output
   
   
   
   
Case #1: Yes Case #2: No
 

Source
2015 Multi-University Training Contest 7
 

对于s,算出s所有位上的数字之和f ,把f加入s后面,求t次操作后的数字能否被11整除。


模拟:s1记录得到数字对11的模数,s记录所有数字之和。




#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main(){
    int n,t,tt=1;

    while(scanf("%d%d",&n,&t),n!=-1){
        int s = 0,s1=n%11;
        while(n){
            s += n%10;
            n /= 10;
        }
        for(int i = 0;i < t; i++){
            int f = s,f1=s;
            while(f){
                s += f%10;
                s1 = s1*10%11;
                f/=10;
            }
            s1 = (s1 + f1) % 11;
        }
        printf("Case #%d: ",tt++);
        if(s1 == 0) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}



你可能感兴趣的:(HDU,2015多校联合训练赛,5373)