HDU - 1014 - Uniform Generator

HDU 1014.Uniform Generator

Time Limit: 2000/1000 MS (Java/Others)     Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999

Sample Output

    3         5    Good Choice

   15        20    Bad Choice

63923     99999    Good Choice

题意:给你一个公式seed(x+1) = [seed(x) + STEP] % MOD,再给你STEP和MOD,让你判断由这个公式求出来的数字是不是涵盖了所有0 - mod-1的数值,如果是就是good choice如果不是就是bad choice

为啥单独把这个拿出来,就是因为我写这道题遇到了一个奇怪的坑点,就是cin和scanf,按理说cin流输入是比scanf慢的,不知为何,我用scanf一直TLE,给我急的没法,找各种题解,发现大部分用cin输入,说试试吧,一下过了,我也就一下蒙圈了,为啥慢的反而A了,最后问了D大神,他说我用scanf后面没加EOF,因为当时题目中没要求文件结束我才没加的,结果因为这个TLE那么多次,感觉心里好亏的,cin是自动判断EOF的。以后记住了,一般都加EOF,泪奔啊 T T….



#include<cstdio>
#include<algorithm>
using namespace std;

int seed[100000];

void ug(int m, int s){    
    seed[0] = 0;
    for (int i = 1; i < m; i++)
        seed[i] = (seed[i - 1] + s) % m;
}

int main()
{
    int s, m;
    while (scanf("%d %d", &s, &m)!=EOF){
        int flag = 1;
        ug(m, s);
        sort(seed, seed + m);
        for (int i = 0; i < m; ++i){
            if (seed[i] != i){
                flag = 0;
                break;
            }
        }
        if (flag)
        printf("%10d%10d Good Choice\n\n", s, m);
        else 
        printf("%10d%10d Bad Choice\n\n", s, m);
    }
}

你可能感兴趣的:(HDU - 1014 - Uniform Generator)