POJ-1936- All in All( 最长公共子序列 && 水题 )

All in All
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 30726   Accepted: 12815

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

Ulm Local 2002


题意:

第一个字符串是否是第二个字符串的子序列(分开的的也算,如第三个测试案例),是,输出Yes,否输出no!

所以说,开头以为超难的.....其实很水的说.....保持做题手感吧.


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main(){
    char a[100001],b[100001];
    while(scanf("%s %s",&a,&b)!=EOF){
        int nSindex = 0;
        int nTindex = 0;
        while(a[nSindex]!='\0'&&b[nTindex]!='\0'){
            if(a[nSindex]==b[nTindex++]){
                nSindex++;
                // printf("%d %d\n",nSindex,nTindex);
            }
        }
        if(a[nSindex]=='\0'){
            printf("Yes\n");
        }else{
            printf("No\n");
        }
    }
    return 0;
}






你可能感兴趣的:(C++,C语言,ACM,poj)