Electrical Outlets

Electrical Outlets

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1919    Accepted Submission(s): 1716


Problem Description
Roy has just moved into a new apartment. Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy's apartment has only one single wall outlet, so Roy can only power one of his electrical appliances at a time. 
Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time. The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now. 
Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered itself to be of any use.
 

Input
Input will start with a single integer 1 <= N <= 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 <= K <= 10, indicating the number of power strips in the test case. Then follow, on the same line, K integers separated by single spaces, O1 O2 . . . OK, where 2 <= Oi <= 10, indicating the number of outlets in each power strip.
 

Output
Output one line per test case, with the maximum number of appliances that can be powered.
 

Sample Input
   
   
   
   
3 3 2 3 4 10 4 4 4 4 4 4 4 4 4 4 4 10 10 10 10
 

Sample Output
   
   
   
   
7 31 37
 

Source
NCPC2005
 

Recommend
zty   |   We have carefully selected several similar problems for you:   2301  2308  2368  2307  2306 
 

Statistic |  Submit |  Discuss |  Note



            边喝农夫山泉边学习英文真是很愉快啊!题目的难点就是!英语看不懂!看看网友的解析!

注意题目中的几个单词 power strips 插座板,我们家里用的。electrical outlet插座板上的插头。弄清楚这个就很清楚了,题目意思就是叫你,墙上只有一个插座空,然后要满足很多用电器的使用,怎么办呢?插座连插座嘛,很简单,所以问题就出来了,这样除了插座板自己有的一个插头要插到上一个去,这样一来还剩多少个孔给其他用电器来用呢???简不简单啊???!!!

             我也不喜欢喝农夫山泉,但是最近没时间,喝农夫山泉只是为了保持手感!然后!学英文才是重点!

          

import java.io.*;
import java.util.*;
public class Main
{

	public static void main(String[] args)
	{
		Scanner input=new Scanner(System.in);
		int n,m,sum;
		int a[]=new int[11];
		n=input.nextInt();
		for(int i=0;i<n;i++)
		{
			sum=0;
			m=input.nextInt();
			for(int j=0;j<m;j++)
			{
				a[j]=input.nextInt();
				sum+=a[j];
			}
			sum=sum-m+1;
			System.out.println(sum);
		}
	}

}

你可能感兴趣的:(java,数据结构,算法)