Lowest Common Multiple Plus

Lowest Common Multiple Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25993    Accepted Submission(s): 10515


Problem Description
求n个数的最小公倍数。
 

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
 

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
 

Sample Input
   
   
   
   
2 4 6 3 2 5 7
 

Sample Output
   
   
   
   
12 70
 

Author
lcy
 

Source
C语言程序设计练习(五)
 

Recommend
lcy
 

该成long long就过了。

#include<iostream>
using namespace std;
long long gcd(int a,int b)
{
    return (a%b==0? b:gcd(b,a%b));
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        long long a,s=1;
      while(n--)
      {
        cin>>a;
        s=(s*a)/(gcd(a,s));
      }
      cout<<s<<endl;
    }
    return 0;
}



你可能感兴趣的:(Lowest Common Multiple Plus)