hdu3535AreYouBusy【分组背包综合题】

Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
 

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
 

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
 

Sample Input
   
   
   
   
3 3 2 1 2 5 3 8 2 0 1 0 2 1 3 2 4 3 2 1 1 1 3 4 2 1 2 5 3 8 2 0 1 1 2 8 3 2 4 4 2 1 1 1 1 1 1 0 2 1 5 3 2 0 1 0 2 1 2 0 2 2 1 1 2 0 3 2 2 1 2 1 1 5 2 8 3 2 3 8 4 9 5 10
 

Sample Output
   
   
   
   
5 13 -1 -1
 

Author
hphp
 

Source
2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU  怪不得AC率这么低

果然之前的背包题都太基础了==

这是一道综合性的背包问题。题目给出了多组工作,每组工作的选择规则不同,有些组至少要选一项,有些组最多选一项,有些组任意选。
  这道题花了很长时间,需要深入理解状态转移才能够明白。数组dp[i][j],表示第i组,时间剩余为j时的快乐值。每得到一组工作就进行一次DP,所以dp[i]为第i组的结果。下面对三种情况进行讨论。
  第一类,至少选一项,即必须要选,那么在开始时,对于这一组的dp的初值,应该全部赋为负无穷,这样才能保证不会出现都不选的情况。状态转移方程为dp[i][k]=max{ dp[i][k],dp[i-1][k-cost[j]]+val[k],dp[i][k-cost[j]]+val[j] }。dp[i][k]是不选择当前工作;dp[i-1][k-cost[j]]+val[k]是选择当前工作,但是是第一次在本组中选,由于开始将该组dp赋为了负无穷,所以第一次取时,必须由上一组的结果推知,这样才能保证得到全局最优解;dp[i][k-cost[j]]+val[j]表示选择当前工作,并且不是第一次取。
  第二类,最多选一项,即要么不选,一旦选,只能是第一次选。所以状态转移方程为dp[i][k]=max{ dp[i][k],dp[i-1][k-cost[j]]+val[k]}。由于要保证得到全局最优解,所以在该组DP开始以前,应该将上一组的DP结果先复制到这一组的dp[i]数组里,因为这一组的数据是在上一组数据的基础上进行更新的。
  第三类,任意选,即不论选不选,选几次都可以,显然状态转移方程为dp[i][k]=max{ dp[i][k],dp[i-1][k-cost[j]]+val[k],dp[i][k-cost[j]]+val[j] }。同样要保证为得到全局最优解,先复制上一组解。
看是看懂了 不知道哪里错了==

WA的:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 1000000
int n,t,m,s;
int dp[130][130];
int get_max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    while(scanf("%d%d",&n,&t)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int cnt=1;cnt<=n;cnt++)
        {
            int cost[130],value[140];
            scanf("%d%d",&m,&s);
            for(int i=1;i<=m;i++) scanf("%d%d",&cost[i],&value[i]);
            if(s==0)
            {
                for(int i=0;i<=t;i++) dp[cnt][i]=-INF;
                for(int i=1;i<=m;i++)
                for(int j=t;j>=cost[i];j--)
                {
                    dp[cnt][j]=get_max(dp[cnt-1][j-cost[i]]+value[i],dp[cnt][j]);
                    dp[cnt][j]=get_max(dp[cnt][j],dp[cnt][j-cost[i]]+value[i]);
                }
            }
            else if(s==1)
            {
                for(int i=0;i<=t;i++) dp[cnt][i]=dp[cnt-1][i];
                for(int i=1;i<=m;i++)
                for(int j=t;j>=cost[i];j--)
                {
                    dp[cnt][j]=get_max(dp[cnt][j],dp[cnt-1][j-cost[i]]+value[i]);
                }
            }
            else
            {
                for(int i=0;i<=t;i++) dp[cnt][i]=dp[cnt-1][i];
                for(int i=1;i<=m;i++)
                for(int j=t;j>=cost[i];j--)
                {
                    dp[cnt][j]=get_max(dp[cnt-1][j-cost[i]]+value[i],dp[cnt][j]);
                    dp[cnt][j]=get_max(dp[cnt][j],dp[cnt][j-cost[i]]+value[i]);
                }
            }
        }

        printf("%d\n",get_max(dp[n][t],-1));
        //else printf("-1\n");
    }
    return 0;
}
标程的==哪里不一样嘛 委屈
#include<stdio.h>
#include<string.h>
#define INF 1000000
#define MAX_LIMT 110
int get_max(int,int);
int main()
{
    int n,t;
    while(scanf("%d%d",&n,&t)!=EOF)
    {
    int i,j,k,dp[MAX_LIMT][MAX_LIMT];
    memset(dp,0,sizeof(dp));
    for(i=1;i<=n;i++)
    {
        int m,s,cost[MAX_LIMT],val[MAX_LIMT];
        scanf("%d%d",&m,&s);
        for(j=1;j<=m;j++)
        {
            scanf("%d%d",&cost[j],&val[j]);
        }
        if(s==0)
        {
            for(j=0;j<=t;j++)
            {
                dp[i][j]=-INF;
            }
            for(j=1;j<=m;j++)
            {
                for(k=t;k>=cost[j];k--)
                {
                    dp[i][k]=get_max( dp[i][k],dp[i][k-cost[j]]+val[j]);
                    dp[i][k]=get_max( dp[i][k],dp[i-1][k-cost[j]]+val[j]);
                }
            }
        }
        else if(s==1)
        {
            for(j=0;j<=t;j++)
            {
                dp[i][j]=dp[i-1][j];
            }
            for(j=1;j<=m;j++)
            {
                for(k=t;k>=cost[j];k--)
                {
                    dp[i][k]=get_max(dp[i][k],dp[i-1][k-cost[j]]+val[j]);
                }
            }
        }
        else
        {
            for(j=0;j<=t;j++)
            {
                dp[i][j]=dp[i-1][j];
            }
            for(j=1;j<=m;j++)
            {
                for(k=t;k>=cost[j];k--)
                {
                    dp[i][k]=get_max( dp[i][k],dp[i][k-cost[j]]+val[j]);
                    dp[i][k]=get_max( dp[i][k],dp[i-1][k-cost[j]]+val[j]);
                }
            }
        }
    }
    dp[n][t]=get_max(dp[n][t],-1);
    printf("%d\n",dp[n][t]);
    }
    return 0;
}
int get_max(int x,int y)
{
    return x>y?x:y;
}



你可能感兴趣的:(dp,HDU,杭电)