Matrix
Time Limit: 3000MS |
|
Memory Limit: 65536K |
Total Submissions: 10282 |
|
Accepted: 3859 |
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1
此题大意:给你一个2维平面,C:(X1,Y1)(X2,Y2)就是将这里范围的点改变:0->1、1->0,Q:(x,y)就是问这个点是什么。
典型的二维树状数组,就是增加一维,写法和一维基本一致,不多说,看下面的吧!!!
链接:http://poj.org/problem?id=2155
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;
int a[1005][1005], n;
int lowbit(int i)
{
return i&(-i);
}
void update(int i, int j, int x) //二维树状数组更新
{
int tj;
while(i <= n)
{
tj = j;
while(tj <= n)
{
a[i][tj] += x;
tj += lowbit(tj);
}
i += lowbit(i);
}
}
int sum(int i, int j) //二维树状数组求和
{
int tj, sum = 0;
while(i > 0)
{
tj = j;
while(tj > 0)
{
sum += a[i][tj];
tj -= lowbit(tj);
}
i -= lowbit(i);
}
return sum;
}
int main()
{
int T, i, j, t, x1, y1, x2, y2;
char ch[2];
scanf("%d", &T);
while(T--)
{
scanf("%d %d", &n, &t);
for(i = 1; i <= n; i++)
for(j = 1; j <= n; j++)
a[i][j] = 0;
while(t--)
{
scanf("%s", ch);
if(ch[0] == 'C')
{
scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
//更新区域-容斥原理
update(x2+1, y2+1, 1);
update(x2+1, y1, 1);
update(x1, y2+1, 1);
update(x1, y1, 1);
}
if(ch[0] == 'Q')
{
scanf("%d %d", &x1, &y1);
printf("%d\n", sum(x1, y1)&1); //该点的值就是sum(x,y)
}
}
printf("\n");
}
return 0;
}