Catch That Cow
Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4444 Accepted Submission(s): 1420
Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
Sample Output
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
struct node
{
int x,times;
};
int man,cow;
bool loca[100001];
int BFS(int x)
{
queue<node>qu;
node now,next;
now.x=x;
now.times=0;
loca[x]=false;
qu.push(now);
while(!qu.empty())
{
now=qu.front();
qu.pop();
next.x=now.x+1;
if(next.x>=0&&next.x<=100000&&loca[next.x])
{
loca[next.x]=false;
next.times=now.times+1;
qu.push(next);
if(next.x==cow)
return next.times;
}
next.x=now.x-1;
if(next.x>=0&&next.x<=100000&&loca[next.x])
{
loca[next.x]=false;
next.times=now.times+1;
qu.push(next);
if(next.x==cow)
return next.times;
}
next.x=now.x*2;
if(next.x>=0&&next.x<=100000&&loca[next.x])
{
loca[next.x]=false;
next.times=now.times+1;
qu.push(next);
if(next.x==cow)
return next.times;
}
}
}
int main()
{
while(scanf("%d%d",&man,&cow)!=EOF)
{
if(man==cow)
{puts("0"); continue;}
memset(loca,true,100001);
printf("%d\n",BFS(man));
}
}