[线段树] POJ 3468 A Simple Problem with Integers

A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 58564   Accepted: 17839
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... ,AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1,A2, ... ,AN. -1000000000 ≤Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... ,Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.
 
换个意思表达这个题目,就是说:
给定Q(1 ≤ Q≤ 100,000)个数A1,A2… AQ,,以及可能多次进行的两个操作:
1)对某个区间Ai … Aj的每个数都加n(n可变)2) 求某个区间Ai … Aj的数的和
 
首先要考虑的就是这个树结点里面存放的信息.如果每个节点里面只放区间数的和,那么在执行求区间和操作时速度会很慢,肯定过不了!
可以这样更新:存放一个区间数的和nSum,再存放一个增量C的累加Inc, 那么求区间和的操作可执行为nSum+Inc*(R-L+1) .
 
在增加时,如果要加的区间正好覆盖一个节点,则增加其节点的Inc值,不再往下走,否则要更新nSum(加上本次增量),再将增量往下传。这样更新的复杂度就是O(log(n))在查询时,如果待查区间不是正好覆盖一个节点,就将节点的Inc往下带,然后将Inc代表的所有增量累加到nSum上后将Inc清0,接下来再往下查询。Inc往下带的过程也是区间分解的过程,复杂度也是O(log(n)).
 
这回用指针来做,顺便练习一下指针的用法。
 
 
 
 
 
#include <iostream>
#include <cstdio>
using namespace std;
struct CNode
{
    int L,R;
    CNode *pLeft,*pRight;
    long long nSum; //原来的和
    long long Inc; //增量C的累加
};
CNode Tree[400010];
int nCount=0;
int Mid(CNode *pRoot)
{
    return (pRoot->L + pRoot->R)/2;
}
void BuildTree(CNode *pRoot,int L,int R)
{
    pRoot->L=L;
    pRoot->R=R;
    pRoot->nSum=0;
    pRoot->Inc=0;
    if(L==R) return ;
    nCount++;
    pRoot->pLeft=Tree+nCount;
    nCount++;
    pRoot->pRight=Tree+nCount;
    BuildTree(pRoot->pLeft,L,(L+R)/2);
    BuildTree(pRoot->pRight,(L+R)/2+1,R);
}
void Insert (CNode *pRoot,int i ,int v)
{
    if (pRoot->L == pRoot->R ){
        pRoot->nSum=v;
        return;
    }
    pRoot->nSum +=v;
    if (i<=Mid(pRoot))
    Insert(pRoot->pLeft,i,v);
    else
    Insert(pRoot->pRight,i,v);
}

void Add(CNode *pRoot,int a,int b,long long c)
{
    if(pRoot->L == a && pRoot->R==b){
    pRoot->Inc += c;
    return ;
    }
    pRoot->nSum += c*(b-a+1);
    if(b<=(pRoot->L + pRoot->R)/2)
        Add(pRoot->pLeft,a,b,c);
    else if(a>=(pRoot->L + pRoot->R)/2+1)
        Add(pRoot->pRight,a,b,c);
    else{
            Add(pRoot->pLeft,a,(pRoot->L+pRoot->R)/2,c);
            Add(pRoot->pRight,(pRoot->L+pRoot->R)/2+1,b,c);
    }
}

long long QuerynSum(CNode *pRoot,int a,int b)
{
    if(pRoot->L==a &&pRoot->R==b)
        return pRoot->nSum+(pRoot->R - pRoot->L +1)*pRoot->Inc;
    pRoot->nSum += (pRoot->R - pRoot->L + 1)* pRoot->Inc;
    Add(pRoot->pLeft , pRoot->L , Mid(pRoot) , pRoot->Inc );
    Add(pRoot->pRight, Mid(pRoot)+1 , pRoot->R , pRoot->Inc);
    pRoot->Inc=0;
    if( b <= Mid(pRoot) ) 
        return QuerynSum(pRoot->pLeft,a,b);
    else if ( a >= Mid(pRoot)+1 ) 
        return QuerynSum(pRoot->pRight,a,b);
    else {
        return ( QuerynSum(pRoot->pLeft , a , Mid(pRoot) ) +
                 QuerynSum(pRoot->pRight, Mid(pRoot)+1, b));
    }
}
int main()
{
    int n,q,a,b,c;
    char cmd[10];
    scanf("%d%d",&n,&q);
    int i;
    nCount=0;
    BuildTree(Tree,1,n);
    for (i=1 ; i <= n;i++)
    {
        scanf("%d",&a);
        Insert(Tree,i,a);
    }
    for (i=0;i<q;i++)
    {
        scanf("%s",cmd);
        if(cmd[0]=='C')
        {
            scanf("%d%d%d",&a,&b,&c);
            Add(Tree,a,b,c);
        }
        else
        {
            scanf("%d%d",&a,&b);
            printf("%I64d\n",QuerynSum(Tree,a,b));
        }
    }
    return 0;
}

关于线段树的题目已经基本建立起框架了,线段树的集训先告一段落,换下一个专题DP啦。

你可能感兴趣的:(算法,线段树,ACM)