lightoj1044--Palindrome Partitioning(记忆化搜索)

Description

A palindrome partition is the partitioning of a string such that each separate substring is a palindrome.

For example, the string "ABACABA" could be partitioned in several different ways, such as {"A","B","A","C","A","B","A"}, {"A","BACAB","A"}, {"ABA","C","ABA"}, or {"ABACABA"}, among others.

You are given a string s. Return the minimum possible number of substrings in a palindrome partition of s.

Input

Input starts with an integer T (≤ 40), denoting the number of test cases.

Each case begins with a non-empty string s of uppercase letters with length no more than 1000.

Output

For each case of input you have to print the case number and the desired result.

Sample Input

3

AAAA

ABCDEFGH

QWERTYTREWQWERT

Sample Output

Case 1: 1

Case 2: 8

Case 3: 5


题意:给你一个字符串,让你找出回文串的最少个数

思路:这是一道动态规划,将一条字符串切割成两条(或者不切割),判断两条子串符合条件的值的和的最小值

优化思路:先给字符串的回文子串打表ok[i][j],在切割的同时判断右半边是否是回文的,是则d[i]=min(d[i],1+d[i-j]),不是说明这种情况必定不是最优

递归代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
string a;
int d[1005][1005];
int ok[1005][1005];
int dp(int l,int r)
{
    if(d[l][r]>=0)return d[l][r];
    if(ok[l][r])return d[l][r]=1;
    int minn=1001;
    for(int i=l; i<r; i++)
        if(ok[l][i])
        minn=min(minn,1+dp(i+1,r));
    return d[l][r]=minn;
}
int main()
{
    int t,fir=1;
    cin>>t;
    while(t--)
    {
        cin>>a;
        memset(d,-1,sizeof(d));
        memset(ok,0,sizeof(ok));
        int n=a.length();
        for(int i=0; i<n; i++)ok[i][i]=1;
        for(int i=0; i<n-1; i++)ok[i][i+1]=(a[i]==a[i+1]);
        for(int len=3; len<=n; len++)
            for(int i=0; i+len-1<n; i++)
            {
                int j=i+len-1;
                ok[i][j]=(a[i]==a[j])&&ok[i+1][j-1];
            }
        printf("Case %d: %d\n",fir++,dp(0,n-1));
    }
    return 0;
}

非递归代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
string a;
int d[1005];
int ok[1005][1005];
int main()
{
    int t,fir=1;
    cin>>t;
    while(t--)
    {
        cin>>a;
        memset(ok,0,sizeof(ok));
        int n=a.length();
        for(int i=0; i<n; i++)ok[i][i]=1;
        for(int i=0; i<n-1; i++)ok[i][i+1]=(a[i]==a[i+1]);
        for(int len=3; len<=n; len++)
            for(int i=0; i+len-1<n; i++)
            {
                int j=i+len-1;
                ok[i][j]=(a[i]==a[j])&&ok[i+1][j-1];
            }
        for(int i=0; i<n; i++)
        {
            d[i]=i+1;
            for(int j=0; j<=i; j++)
                if(ok[j][i])
                {
                    if(j==0)
                        d[i]=1;
                    else
                        d[i]=min(d[i],1+d[j-1]);
                }
        }
        printf("Case %d: %d\n",fir++,d[n-1]);
    }
    return 0;
}




你可能感兴趣的:(动态规划)