hdu 3346

水题,太简单了,就是写代码,想都不用想

Problem Description
To Chinese people, 8 is a lucky number. Now your task is to judge if a number is lucky.
We say a number is lucky if it’s a multiple of 8, or the sum of digits that make up the number is a multiple of 8, or the sum of every digit’s square is a multiple of 8.
 

 

Input
The first line contains an integer stands for the number of test cases.
Each test case contains an integer n (n >= 0).
 

 

Output
For each case, output “Lucky number!” if the number is lucky, otherwise output “What a pity!”.
 

 

Sample Input
   
   
   
   
2 0 8
 

 

Sample Output
   
   
   
   
Lucky number! Lucky number!
source code:
#include<iostream>
#include<cstdlib>
using namespace std;
int main()
{
    int n,m,sum1,sum2;
    cin>>n;
    while(n--)
    {
    cin>>m;
    sum1=0;
    sum2=0;
    if(m%8==0)
    {cout<<"Lucky number!"<<endl;}
    else
    {
    while(m)
    {
    sum1+=m%10;
    sum2+=(m%10)*(m%10);
    m=m/10;
    }
    if(sum1%8==0||sum2%8==0)
    cout<<"Lucky number!"<<endl;
    else
    cout<<"What a pity!"<<endl;
    }
    }
    return 0;
}

你可能感兴趣的:(hdu 3346)