[暴力搜索] poj 3187 Backward Digit Sums

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5140 Accepted: 2971
Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

3   1   2   4

  4   3   6

    7   9

     16

Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.
Input

Line 1: Two space-separated integers: N and the final sum.
Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input

4 16
Sample Output

3 1 2 4
Hint

Explanation of the sample:

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

输入n和sum,做与杨辉三角类似的累加计算
枚举第一行所有可能出现的排列,找到最小的满足sum的排列。
n最大等于10,于是直接暴力搞起~

#include <iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int num[11];
int maze[11][11];
int sum,n;
bool Search()
{
    for(int i =1;i<=n;i++)
        maze[1][i] = num[i];

    for(int i =2;i<=n;i++)
        for(int j = 1; j<=n-i+1;j++)
            maze[i][j] = maze[i-1][j] + maze[i-1][j+1];
    if(maze[n][1] == sum) return true;
    else return false;

}
int main()
{
    scanf("%d%d",&n,&sum);
    for(int i = 1;i<=n;i++)
        num[i] = i;
    do
    {
        bool flag = Search();
        if (flag)break;
    }while(next_permutation(num+1,num+1+n));
    for(int i = 1;i<=n;i++)
        printf("%d%c",num[i],i==n ? '\n':' ');
}

你可能感兴趣的:([暴力搜索] poj 3187 Backward Digit Sums)