HDU 1060 Leftmost Digit

Leftmost Digit

                                                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                         Total Submission(s): 13487    Accepted Submission(s): 5176


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
   
   
   
   
2 3 4
 

Sample Output
   
   
   
   
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
Ignatius.L
 
分析:
将一个数表示成科学计数法为:num = x1 * 10 ^ n,例如:123 = 1.23 * 10^2。这里求的是 x1 的整数部分。
将科学计数法表达式两边取以10为底的对数:lg(num) = x2;即10 ^ x2 = num。
10 ^ x2 可分为 10 ^ (x2的整数部分) * 10 ^ (x2的小数部分);
对应关系:                ||                                 ||
                             10 ^ n                 *           x1
此时我们求 10 ^ (x2的小数部分) 这个数的整数部分就行了。
代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{

    int t, n;
    double x;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);    //num = n * n
        x = n * log10(1.0 * n);    //x 为上面的x2
        x -= (__int64)x;     //取x2的小数部分
        n = pow(10, x);    //10 ^ (x2的小数部分)
        printf("%d\n", n);  //用 %d 输出10 ^ (x2的小数部分) 这个数的整数部分
    }
    return 0;
}




你可能感兴趣的:(HDU 1060 Leftmost Digit)