POJ 1852 Ants

Ants
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13787   Accepted: 6005

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207


题意:

n只蚂蚁以每秒1cm的速度在长度为l的杆子上爬行,到端点就掉落,碰头就反向,求所有蚂蚁掉落的最短时间和最长时间

分析:

最短好想,其实两只蚂蚁相遇后,当他们保持原样交错而过继续前行也不会有任何问题,所有求最长的时间,只要求蚂蚁到杆子端点的最大距离就可以了


#include <cstdio>
#include <algorithm>
using namespace std;

int t, l, n;
int x[1000001];

void solve()
{
    int mint = 0, maxt = 0;
    for (int i = 0; i < n; i++)
        mint = max(mint, min(x[i], l - x[i]));  //计算最短时间
    for (int i = 0; i < n; i++)
        maxt = max(maxt, max(x[i], l - x[i]));  //计算最长时间
    printf("%d %d\n", mint, maxt);
}

int main()
{
    scanf("%d", &t);
    while (t--){
        scanf("%d%d", &l, &n);
        for (int i = 0; i < n; i++)
            scanf("%d", &x[i]);
        solve();
    }
    return 0;
}


你可能感兴趣的:(POJ 1852 Ants)