1102. Invert a Binary Tree

1102. Invert a Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
#include<iostream>
#include<stdio.h>
#include<vector>
#include<queue>
#include<string>
#include<algorithm>
using namespace std;

struct Node
{
	int lchild;
	int rchild;
	int parent;
	
	Node():lchild(-1),rchild(-1),parent(-1){}
}buf[10];

int findRoot(int x)
{
	if(buf[x].parent != -1)
		return findRoot(buf[x].parent);
	return x;
}

vector<int> ans;//获得遍历顺序装来,然后进行格式化输出 
void levelOrder(int root)
{
	queue<int> que;
	que.push(root);
	while(!que.empty())
	{
		int cur = que.front();
		ans.push_back(cur);
		que.pop();
		
		if(buf[cur].lchild != -1)
			que.push(buf[cur].lchild);
		if(buf[cur].rchild != -1)
			que.push(buf[cur].rchild);
	}
}


void inOrder(int root)
{
	if(buf[root].lchild != -1)
		inOrder(buf[root].lchild);
	ans.push_back(root);
	if(buf[root].rchild != -1)
		inOrder(buf[root].rchild);
}

void print(vector<int> vx)
{
	for(int i = 0; i < vx.size(); i ++)
		if(i)
			printf(" %d", vx[i]);
		else
			printf("%d", vx[i]);
	printf("\n");
}

int main()
{
	//freopen("F://Temp/input.txt", "r", stdin);
	int n;
	scanf("%d", &n);
	
	for(int i = 0; i < n; i ++)
	{
		string l, r;
		cin>>r>>l;
		if(r != "-")
		{
			buf[i].rchild = atoi(r.c_str());
			buf[atoi(r.c_str())].parent = i;
		}
		if(l != "-")
		{
			buf[i].lchild = atoi(l.c_str());
			buf[atoi(l.c_str())].parent = i;
		}
	}
	
	int root = findRoot(0);
	ans.clear();
	levelOrder(root);
	print(ans);
	
	ans.clear();
	inOrder(root);
	print(ans);
	
	return 0;
}


你可能感兴趣的:(1102. Invert a Binary Tree)