UVA 10177 (2/3/4)-D Sqr/Rects/Cubes/Boxes

(2/3/4)-D Sqr/Rects/Cubes/Boxes?

Input: standard input

Output: standard output

Time Limit: 2 seconds

 

You can see a (4x4) grid below. Can you tell me how many squares and rectangles are hidden there? You can assume that squares are not rectangles. Perhaps one can count it by hand but can you count it for a (100x100) grid or a (10000x10000) grid. Can you do it for higher dimensions? That is can you count how many cubes or boxes of different size are there in a (10x10x10) sized cube or how many hyper-cubes or hyper-boxes of different size are there in a four-dimensional (5x5x5x5) sized hypercube. Remember that your program needs to be very efficient. You can assume that squares are not rectangles, cubes are not boxes and hyper-cubes are not hyper-boxes. 

 

Fig: A 4x4 Grid

Fig: A 4x4x4 Cube

 

 

Input

The input contains one integer N (0<=N<=100) in each line, which is the length of one side of the grid or cube or hypercube. As for the example above the value of N is 4. There may be as many as 100 lines of input.

 

Output

For each line of input, output six integers S2, R2, S3, R3, S4, R4 in a single line where S2 means no of squares of different size in ( NxN)two-dimensional grid, R2 means no of rectangles of different size in (NxN) two-dimensional grid. S3, R3, S4, R4 means similar cases in higher dimensions as described before.  

 

Sample Input:

1
2
3

Sample Output:

1 0 1 0 1 0
5 4 9 18 17 64
14 22 36 180 98 1198

题意:输入n 求出2维,3维,4维中,正方形个数, 和除了正方形以外的矩形个数。

推出公式: 对k维。正方形个数为1 ^ k + 2 ^ k + 3 ^ k +....+ n ^ k;

矩形总个数为n! ^ k;

除了正方以外的矩形个数为 矩形总个数 - 正方形个数。。

记得用longlong,,, 话说。。如果是3维 4维貌似不叫正方形矩形- - 啊哈哈哈 ,不用在意这种小事

#include <stdio.h>
#include <string.h>
#include <math.h>

int n;
long long s2,r2,s3,r3,s4,r4;
int main()
{
    while (scanf("%d", &n) != EOF)
    {
	s2 = r2 = s3 = r3 = s4 = r4 = 0;
	for (int i = 1; i <= n; i ++)
	{
	    s2 += pow(i, 2);
	    s3 += pow(i, 3);
	    s4 += pow(i, 4);
	}
	long long jie = 0;
	for (int i = 1; i <= n; i ++)
	    jie += i;
	r2 = pow(jie, 2) - s2;
	r3 = pow(jie, 3) - s3;
	r4 = pow(jie, 4) - s4;
	printf("%lld %lld %lld %lld %lld %lld\n", s2, r2, s3, r3, s4, r4);
    }	
    return 0;
}



你可能感兴趣的:(UVA 10177 (2/3/4)-D Sqr/Rects/Cubes/Boxes)