1015. Reversible Primes (20)

http://www.patest.cn/contests/pat-a-practise/1015


reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
#include <stdio.h>
#include <math.h>
int isPrime(int x){
 int i,t;
 if(x == 0 || x == 1) return 0;
 if(x == 2) return 1;
 t = x >> 1;
 for(i = 2;i < t;i++)
  if(x % i == 0)
   return 0;
 return 1;
}
int f(int x,int radix){
 int n = 0,tmp_x;
 int i;
 int a[20],cnt;
 cnt = 0;
 tmp_x = x;
 while(x){
  a[cnt++] = x % radix;
  x = x / radix;
 }
 x = tmp_x;
 for(i = 0;i < cnt;i++){
  n += a[i] * pow(radix,cnt - 1 - i);
 }
 return isPrime(x) && isPrime(n);
}
int main(){
 int D;
 int n;
 char *p[] = {"No","Yes"};
 while(scanf("%d",&n) && n>=0){
  scanf("%d",&D);
  printf("%s\n",p[f(n,D)]);
 }
 return 0;
}


你可能感兴趣的:(1015. Reversible Primes (20))